Wizkers:Radio 0.3.0, now with experimental remote operations


#1

Hi everyone,

With this long (American) Labor Day week-end comes a new Wizkers:Radio release, with quite a few new capabilities and improvements:

Telepost LP-100A support

This new instrument is a really cool RF Wattmeter with a lot of interesting capabilities. You can read all about it on the Telepost site. The LP-100A supports a simple serial data output, which made it an ideal candidate for Wizkers:Radio.

This first implementation is a fairly straightforward remote display for the LP-100A which mixes a semi-realistic rendering of the actual device and controls in the usual Wizkers:Radio tradition, but takes a few liberties to present more information than the LP-100A itself can do on its 2-line VFD screen.

The following LP-100A capabilities are supported:

  • SWR Bargraph
  • Power bargraph (15W, 100W and 1500W autoscale)
  • Alarms: visual and audio with a 600Hz annoying beep
  • Alarm setting and Peak/Avg/Tune setting

In a nutshell, pretty much everything the LP-100A will let you do remotely.

The bargraph update speed is at 2Hz right now, with very little CPU usage. It is probably not practical to go above this value, display-wise, but we are open to comments.

We are especially pleased with this new instrument, because this fills a gap whereby the only OS that was supported by the official Telepost utility was Windows. You can now remotely display your LP-100A on pretty much every device on the planet - save for iOS, but that’s another story altogether.

Many thanks to Larry Phipps from Telepost for his support on this project!

New experimental “Wizkers Netlink” remote operations protocol

While using Wizkers:Radio over a VNC display or a Mac “screen sharing” works really well for remote operations, sometimes you just want to be running Wizkers on your Android device or laptop and access a remote rig. For this reason, we have created the “Network Link” output for Wizkers. Think of it as a “wizkers to wizkers” link. Here is how it works:

  • On your local computer - the one connected to your rig, setup your transceiver as usual, and go to the “Data Outputs” menu. There, you can now create a “Network Link” output. This output only has one setting: the local IP address, which defaults to 127.0.0.1. You will need to change this to your local computer’s IP address, usually starting with “192.168.” or “10.” . Make sure the output is enabled as shown on the screeenshot below. Go back to the main Wizkers menu and connect to the rig.

  • On a remote computer or phone/tablet, setup the same transceiver, but in the “Serial Port” dropdown menu, you will see a new “Wizkers Netlink” option. There, input the IP address of the computer that is connected to your rig. If you want to do this over the Internet, you will need to setup a VPN to your home network so that you can reach your remote computer. Do not open the port on your local router, the Wizkers Netlink protocol does not use authentication - yet - and it is a bad idea. More on this at a later stage.

… and that’s pretty much it! You can now connect to your remote rig from your laptop/phone/tablet just as if it was local, and this uses way less network bandwidth than a VNC link.

This new protocol is very experimental and is only supported on the following radios/instruments so far:

  • Elecraft KX2

  • Elecraft KX3

  • Elecraft K3

  • Telepost LP-100A

    As a side note, even taking remote screenshots of a PX3 works fine, so don’t be afraid to try this out, play with it, break it and report!

As a quick example: LP-100A displayed on Android, connected to a Wizkers:Radio running on a remote Mac:

What now ?

As usual, you can grab the latest version of Wizkers:Radio on the stores below. You will soon have an option to download a Mac/Windows/Linux version that does not rely on the Chrome store, stay tuned on that one!

The Chrome version is available, and the Android versions are slowly making their way to their respective stores, be patient and your phone will upgrade automatically!

Side note: we got a couple of reports of Wizkers:Radio not upgrading properly in some cases. We haven’t been able to identify a root cause at this point, but uninstalling the app from your device and re-installing it solves the problem, so if you ever run into this, try to do just that…

Get it on Google PlayGet it on the Chrome app store


#2

I got the update, and set up chrome and wizkers on my laptop. Followed the above instructions, but when I try to connect the laptop it fails with connection error, could not open connection to remote device. I left the port at your default. my ip was 192.168.1.150. Suggestions on what to try?
doug


#3

should have added both are window 8 on the local wifi network


#4

Hmm. Are you trying remote operations, or are you using a Piglet-style Serial-to-TCP converter?

If you are trying remote, it looks like one of your machines is Windows 8, what is the other one ?

Ed


#5

trying the new remote function, both systems are win 8 on a local wireless network


#6

There might be a Windows firewall issue - not super familiar with Windows, but you can probably either allow Wizkers:Radio to accept incoming connections, or disable the firewall temporarily to test whether this is the issue ? Don’t leave the firewall open though, close it as soon as you are done experimenting!


#7

WB6vac did you ever get this to work? I am having the the same
problem using 2 windows 10 computers. The local pc connects to
the radio just fine, but on the remote PC I get the same connection
error message you did.


#8

no I did not, and had to put it on the shelf to get some rpt site work done before the snow came. The local pc did the connects to the kx3 and all of that worked, just could never get the "remote"pc to link even while setting on the same desk going through my local wifi.


#9

Thanks, I also tried with the kx3 connected to a Linux box, no luck, then I tried connecting remotely from 2 different Android devices. Still no luck. I have come to the conclusion remote operation is a myth.


#10

Not a myth, guys :slight_smile: But I have not documented it properly yet. I am busy with Apple App store submission these days (nightmare), but as soon as this is done, I will shoot a video on how to configure it. Hang tight!